What's new

Welcome to Ruzgar.com

Join us now to get access to all our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, and so, so much more. It's also quick and totally free, so what are you waiting for?

Ask question

Ask questions and get answers from our community

Answer

Answer questions and become an expert on your topic

Contact us

Contact the site administrator directly.

Groups

Just like Facebook join them and enjoy.

DirectAdmin Php Selector Settings and Compilation Error Solution

ruzgar

Administrator
Staff member
Joined
Oct 3, 2021
Messages
37
Reaction score
0
Points
6
Hello there,

Unfortunately, sometimes the Directadmin php settings system does not work from Admin Panel.
For example, let's say we want to install php 5.6 for old sites and php 7.4 for new sites:
Just Login to Direct Admin from SSH and paste codes below:

Code:
cd /usr/local/directadmin/custombuild
./build set php1_release 5.6
./build set php2_release 7.4
./build set php1_mode php-fpm
./build set php2_mode php-fpm
./build update
./build php d
./build rewrite_confs

or if you want to use 4 different version like php version 5.3, 5.4, 5.6 and 7.4 Just use the codes:


Code:
cd /usr/local/directadmin/custombuild
./build set php1_release 7.4
./build set php2_release 5.6
./build set php3_release 5.4
./build set php4_release 5.3
./build set php1_mode php-fpm
./build set php2_mode php-fpm
./build set php3_mode php-fpm
./build set php4_mode php-fpm
./build update
./build php d
./build rewrite_confs

The codes will install Php 7.4i 5.6, 5.4 and 5.3. You can change the versions as you wish.

Note I don't recommend PHP8 yet. ioncube for PHP8 is currently not defined.
 
shape1
shape2
shape3
shape4
shape5
shape6
Top